티스토리 뷰

Android API 17부터였나.. 아마 그때부터 Android Dependencies 가 추가됫던것같다.

오래전이지만 아직도 종종 물어보시는분이 계셔서 포스팅한다.

Android Dependencies 가 없는 프로젝트라면 오래전 생성된 프로젝트일것이다.

하지만 이것은 빌드도 정상, 어플실행도 정상이지만 Library를 사용하는 부분이 나오면 어플이 Library를 찾지못해 죽어버린다.


Library 폴더는 libs 일것이다. 만약 lib 로 되어있다면 libs 로 폴더명을 변경해주자.

그리고 아래와같이 해당프로젝트의 .classpath 파일을 열어 아래와같이 한줄만 추가해주면 끝난다.

해당프로젝트에 Android Denpendencies가 바로 추가된것을 볼 수있다.


참고로.. 알고있겠지만 .classpath 파일은 Navigator 나 탐색기를 이용해야 보인다.


<classpathentry kind="con" path="com.android.ide.eclipse.adt.LIBRARIES"/>


*전


*후



추가하고 나면 바로 반영되지만 혹 반영되지 않을경우 Close Project 한 후 다시 Open Project를 하면 반영되어있을것이다.


[작성자]  devbible.tistory.com

댓글
댓글쓰기 폼